CVE
CVE-2026-28780
- 9.8
- CVSS 3.1
- 1
- story
What it is
Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
From the National Vulnerability Database
Official references
4 sourcesRegistries
RegistryNVDScore, weakness and every referenceRegistryCVE.orgThe official CVE recordAdvisories, fixes & analysis
Fixhttpd.apache.org/security/vulnerabilities_24.htmlAnalysisopenwall.com/lists/oss-security/2026/05/05/9